Koha Test Wiki MediaWiki MySQL Binary

One of a series of test instances for migrating the Koha Wiki MediaWiki database.

For the current Koha Wiki, visit https://wiki.koha-community.org .

Acquisitions funds endpoint RFC

From Koha Test Wiki MediaWiki MySQL Binary

Jump to: navigation, search
Home
Koha > Technical > Development > RFCs

Actions and routes

Description Action Proposed path
List funds
 GET
 /acquisitions/funds
Add a fund
 POST
 /acquisitions/funds
Get a fund
 GET
 /acquisitions/funds/{fund_id}
Overwrite a fund
 PUT
 /acquisitions/funds/{fund_id}
Delete a fund
 DELETE
 /acquisitions/funds/{fund_id}
Partially update a fund
 PATCH
 /acquisitions/funds/{fund_id}
Description Action Proposed path
List fund users
 GET
 /acquisitions/funds/{fund_id}/patrons
Add a fund user
 POST
 /acquisitions/funds/{fund_id}/patrons
Delete a fund user
 DELETE
 /acquisitions/funds/{fund_id}/patrons/{patron_id}

Note: it would be correct to pick users over patrons in this case. This should be voted, though.


Fund object definition

DB schema API Comments
budget_idfund_id Name changed to match UI
budget_codecode
budget_namename
budget_branchcodelibrary_id
budget_amounttotal_amount
budget_encumbwarn_at_percentage
budget_expendwarn_at_amount
budget_notesnotes
budget_period_idbudget_id
timestamptimestamp
budget_owner_idfund_owner_id
budget_permissionfund_access
sort1_authcat statistic1_auth_value_category
sort2_authcatstatistic2_auth_value_category


Comments

  • (fixed) What's budget in the code is fund in the GUI, which is quite confusing as is. We need to be careful to get it right for the API.
  • (fixed) What's the reason to remove encumb and expend?
  • fund_access: 1=owner, owner and users = 3, owner, users, and library = 2. How to translate this best into the API? Use words instead of magic numbers?
  • statistics*_auth... also appears in the orders endpoint. We need to make them consistent.

--Kfischer 16:39, 10 April 2018 (EDT)

Personal tools